NetVision-Technik

Zurück   NetVision-Technik > Forum > Server > Webserver

Webserver Fragen zum Apache, MySQL-Einrichtung und was sonst noch mit WebServern zu tun hat

Antwort
 
Themen-Optionen Ansicht
Alt 06.09.2018, 17:55   #1
wasnun
Erfahrener Benutzer
Punkte: 6.916, Level: 54 Punkte: 6.916, Level: 54 Punkte: 6.916, Level: 54
Levelaufstieg: 83% Levelaufstieg: 83% Levelaufstieg: 83%
Aktivität: 66,7% Aktivität: 66,7% Aktivität: 66,7%
Letzte Erfolge
 
Benutzerbild von wasnun
 
Registriert seit: 26.02.2010
Alter: 22
Beiträge: 226
Abgegebene Danke: 0
Erhielt 1 Danke für 1 Beitrag
Downloads: 21
Uploads: 0
Nachrichten: 9
Renommee-Modifikator:
0 wasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geraten
Standard debian 9 und nginx error anzeige fehler

nutze bei dem neuen server debian 9, php7 ect.


für ein altes projekt(pic speicher) habe ich einer Seite/ip php 5.6-fpm zugeordnet. laut phpinfo(); nutzt die seite auch 5.6


jetzt bekomme ich bei dem aufruf der url nach dem ich auf login gedrückt habe nur auf der takelogin eine leere weiße seite.


in den logs steht leider nix drin. (sind leer)


Wie kann ich auf der seite die fehler anzeigen lassen ?
nutze nginx


mit error_reporting in der php /php.ini .htaccess funktioniert es leider nicht.

Geändert von wasnun (06.09.2018 um 18:00 Uhr)
wasnun ist offline   Mit Zitat antworten Nach oben
Alt 07.09.2018, 10:24   #2
pat
Profi
Punkte: 15.575, Level: 80 Punkte: 15.575, Level: 80 Punkte: 15.575, Level: 80
Levelaufstieg: 45% Levelaufstieg: 45% Levelaufstieg: 45%
Aktivität: 0% Aktivität: 0% Aktivität: 0%
Letzte Erfolge
 
Benutzerbild von pat
 
Registriert seit: 12.01.2011
Ort: @home
Alter: 36
Beiträge: 577
Abgegebene Danke: 99
Erhielt 133 Danke für 33 Beiträge
Downloads: 4
Uploads: 0
Nachrichten: 747
Renommee-Modifikator:
1625 pat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehenpat genießt hohes Ansehen
Standard

/etc/php/7.0/fpm/pool.d/www.conf
__________________
il faut de tout pour faire un monde.
pat ist offline   Mit Zitat antworten Nach oben
Alt 07.09.2018, 13:17   #3
wasnun
Erfahrener Benutzer
Punkte: 6.916, Level: 54 Punkte: 6.916, Level: 54 Punkte: 6.916, Level: 54
Levelaufstieg: 83% Levelaufstieg: 83% Levelaufstieg: 83%
Aktivität: 66,7% Aktivität: 66,7% Aktivität: 66,7%
Letzte Erfolge
 
Benutzerbild von wasnun
 
Registriert seit: 26.02.2010
Alter: 22
Beiträge: 226
Abgegebene Danke: 0
Erhielt 1 Danke für 1 Beitrag
Themenstarter Themenstarter
Downloads: 21
Uploads: 0
Nachrichten: 9
Renommee-Modifikator:
0 wasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geraten
Standard

jetzt verstehe ich nix mehr =D
hab in den datein jetzt das php_flag ect. an gemacht.


jetzt wird die login seite richtig angezeigt und auch die takelogin (wenn bsp. falsches PW eingegeben wird) aber keine fehler anzeige.
und wenn login ok ist komme ich auf die index und werd dann wieder ausgelogt und wenn ich auf was klicke komme ich wieder auf die login seite


egal werd die seite jetzt komplett neu machen mit php7 dann

Geändert von wasnun (08.09.2018 um 18:15 Uhr)
wasnun ist offline   Mit Zitat antworten Nach oben
Alt 07.09.2018, 15:03   #4
Stifler
König
Punkte: 30.598, Level: 100 Punkte: 30.598, Level: 100 Punkte: 30.598, Level: 100
Levelaufstieg: 0% Levelaufstieg: 0% Levelaufstieg: 0%
Aktivität: 33,3% Aktivität: 33,3% Aktivität: 33,3%
Letzte Erfolge
 
Benutzerbild von Stifler
 
Registriert seit: 14.02.2011
Ort: Graz
Alter: 33
Beiträge: 1.447
Abgegebene Danke: 74
Erhielt 200 Danke für 37 Beiträge
Downloads: 10
Uploads: 0
Nachrichten: 6198
Renommee-Modifikator:
2763 Stifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes AnsehenStifler genießt hohes Ansehen
Standard

äm also bei mir php7.1-fpm schaut das so aus

/etc/php/7.1/fpm/pool.d
nano  www.conf


und ganz unten habe ich folgendes eingefügt:

Code:
php_admin_value[error_log] = /var/log/php7-fpm-www.log
php_admin_flag[log_errors] = on
php_value[session.save_handler] = files
php_value[session.save_path] = /tmp
error_reporting kann dir vl weiterhelfen
__________________

Geändert von Stifler (07.09.2018 um 15:06 Uhr)
Stifler ist offline   Mit Zitat antworten Nach oben
Alt 08.09.2018, 18:17   #5
wasnun
Erfahrener Benutzer
Punkte: 6.916, Level: 54 Punkte: 6.916, Level: 54 Punkte: 6.916, Level: 54
Levelaufstieg: 83% Levelaufstieg: 83% Levelaufstieg: 83%
Aktivität: 66,7% Aktivität: 66,7% Aktivität: 66,7%
Letzte Erfolge
 
Benutzerbild von wasnun
 
Registriert seit: 26.02.2010
Alter: 22
Beiträge: 226
Abgegebene Danke: 0
Erhielt 1 Danke für 1 Beitrag
Themenstarter Themenstarter
Downloads: 21
Uploads: 0
Nachrichten: 9
Renommee-Modifikator:
0 wasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geratenwasnun ist in Verruf geraten
Standard

error_reporting geht ja nicht warum auch immer. hab es in php/5.6 /7.0/7.1/7.2 geändert.
(in der www cof aber auch in der php.ini ect.



in der .ht datei im ordner, in der bt.php und auf den seiten.


trotzden werden keine fehler angezeigt
wasnun ist offline   Mit Zitat antworten Nach oben
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 08:24 Uhr.


Powered by vBulletin® Version 3.8.9 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Template-Modifikationen durch TMS